Fink

Package xmkmf-1.0.6-1201

SystemCVS/rsync Source DistributionsDebian Binary Distributions
stable RSS feed stableunstable RSS feed unstablestableunstable
10.9/x86_64
 
 
10.8/x86_64
 
 
10.7/x86_64
1.0.6-1201
 
 
 
10.6/x86_64
 
 
 
10.6/i386
 
 
 
10.5/i386 *
 
 
 
10.5/powerpc *
 
 
10.4/i386 *
 
 
 
10.4/powerpc *
 
 
 
10.3/powerpc *
 
 
 
 
10.2-gcc3.3/powerpc *
 
 
 
 
10.2/powerpc *
 
 
 
 
10.1/powerpc *
 
 
 
 
Description:   X11 legacy build tools (1.0.6-1201)
Under 10.5, this package provides the xmkmf script and the imake executable and their supporting config files that are no longer supplied with the X11R7 release from x.org. Under 10.4, this package simply gives symlinks to the appropriate files in /usr/X11R6 (so that .info files which work in both 10.4 and 10.5 can easily be constructed). Thanks to Martin Costabel and Benjamin Reed for earlier versions.
Usage Hints:   
In order to use xmkmf and imake to compile legacy packages (under 10.4 or 10.5), one should have a BuildDepends on the present package, and supply export PATH=/sw/lib/xmkmf/bin:$PATH export IMAKEINCLUDE=-I/sw/lib/X11/config in the CompileScript and InstallScript of the packages. Failing to do this runs the risk that some users may not have xmkmf and/or imake (or the necessary config files) available at build time.
Section:   devel
Maintainer:   Dave Morrison <drmATfinkprojectDOTorg>
Website:   http://xorg.freedesktop.org/
License:   BSD
Info-File:   dists/10.7/stable/main/finkinfo/devel/xmkmf.info
CVS log, Last Changed: Mon, 30 Sep 2013 11:26:05 (UTC)

Section list - Flat package list - Search packages

(*) = Unsupported distribution.